Servlet 3.0 API的Maven依赖?

问题

如何告诉Maven 2加载Servlet 3.0 API?

我试过了:

<dependency>
    <groupId>javax.servlet</groupId>
    <artifactId>servlet-api</artifactId>
    <version>3.0</version>
    <scope>provided</scope>
</dependency>

我使用http://repository.jboss.com/maven2/但是什么存储库是正确的?
附录:
它适用于整个Java EE 6 API的依赖项和以下设置:

<repository>
    <id>java.net</id>
    <url>http://download.java.net/maven/2</url>
</repository>

<dependency>
    <groupId>javax</groupId>
    <artifactId>javaee-api</artifactId>
    <version>6.0</version>
    <scope>provided</scope>
</dependency>

我更愿意只将Servlet API添加为依赖项,但"Brabster"可能是正确的,因为Java EE 6配置文件已经替换了单独的依赖项。是否有来源证实了这一假设?


#1 热门回答(447 赞)

这似乎最近添加:
http://repo1.maven.org/maven2/javax/servlet/javax.servlet-api/3.0.1/

<dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>javax.servlet-api</artifactId>
        <version>3.0.1</version>
        <scope>provided</scope>
</dependency>

#2 热门回答(109 赞)

我更愿意只将Servlet API添加为依赖项,

说实话,我不确定为什么,但没关系......

Brabster单独的依赖项已被Java EE 6 Profiles取代。是否有来源证实了这一假设?

来自Java.net的maven存储库确实为WebProfile提供了以下工件:

<repositories>
  <repository>
    <id>java.net2</id>
    <name>Repository hosting the jee6 artifacts</name>
    <url>http://download.java.net/maven/2</url>
  </repository>
</repositories>        
<dependencies>
  <dependency>
    <groupId>javax</groupId>
    <artifactId>javaee-web-api</artifactId>
    <version>6.0</version>
    <scope>provided</scope>
  </dependency>
</dependencies>

这个jar包括Servlet 3.0,EJB Lite 3.1,JPA 2.0,JSP 2.2,EL 1.2,JSTL 1.2,JSF 2.0,JTA 1.1,JSR-45,JSR-250。

但据我所知,没有什么可以说这些API不会单独分发(在java.net资源库或其他地方)。例如(好吧,可能是特定情况),JSF 2.0 API可以单独使用(在java.net存储库中):

<dependency>
   <groupId>com.sun.faces</groupId>
   <artifactId>jsf-api</artifactId>
   <version>2.0.0-b10</version>
   <scope>provided</scope>
</dependency>

实际上,你可以从225267820获取javax.servlet-3.0.jar并将其安装在你自己的存储库中。


#3 热门回答(35 赞)

或者你可以将Central Maven Repository与Servlet 3.0 API一起使用,该API也是为Tomcat Server 7.0.X提供的

<dependency>
        <groupId>org.apache.tomcat</groupId>
        <artifactId>tomcat-servlet-api</artifactId>
        <version>7.0.21</version>
        <scope>provided</scope>
    </dependency>

从这里:http://repo2.maven.org/maven2/org/apache/tomcat/tomcat-servlet-api/7.0.21/