在哪里构建:gradle:2.1.0-alpha3?

我刚刚安装了Android Studio版本2.1预览版3(AI-143.2682553)当我运行我的项目时出现错误,它说:

找不到com.android.tools.build:gradle:2.1.0-alpha3 . 在以下位置搜索:https://jcenter.bintray.com/com/android/tools/build/gradle/2.1.0-alpha3/gradle-2.1.0-alpha3.pom https://jcenter.bintray.com/com/android/tools/build/gradle/2.1.0-alpha3/gradle-2.1.0-alpha3.jar

当我查看Jcenter存储库时,它只有2.1.0-alpha1 https://jcenter.bintray.com/com/android/tools/build/gradle/

所以我得到为什么它找不到alpha3,但是当我将build.gradle更改为2.1.0-alpha1时,它说:“项目使用的是不兼容的android Gradle插件版本 . 要继续打开项目,IDE将Android Gradle插件更新为2.1.0-alpha3版“

这似乎不存在吗?

回答(2)

3 years ago

Gradle 1.5.0版的Android插件不支持Instant Run . 请更新到2.1.0-alpha3版

我有类似的问题,我通过在android studio中更新它修复它,就像这样!
setting

更新后,我发现了gradle的变化

dependencies {
    classpath 'com.android.tools.build:gradle:2.1.0-alpha3'
   // classpath 'com.android.tools.build:gradle:1.5.0'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

 buildToolsVersion '24 rc1'//buildToolsVersion "23.0.2"

3 years ago

我有2.1.0-alpha3的类似问题..我的项目无法编译..我使用早期版本2.1.0-alpha1 @ http://tools.android.com/download/studio/builds/android-studio-2-1-preview-1

通过卸载和安装旧版本 . 希望可能有所帮助 .