当程序必须链接到在构建机器上使用的libstdc版本时?

我使用gcc 4.9.2(libstdc .so.6.0.20)构建了一些示例c应用程序 . 我可以在配备gcc 4.6.3((libstdc .so.6.0.16)的虚拟机上运行该程序 . 有时,应用程序无法在与构建环境不同的环境中运行(例如libstdc . so.6.0.16 vs libstdc .so.6.0.20) . 当程序必须链接到在构建机器上使用的libstdc版本时?你能给我一些例子(带源代码)吗?

回答(0)