无法加载Apache mod_ssl

尝试在Apache 2.4.25上启用mod_ssl模块,我收到以下错误:

httpd:/ld01/otsweb/build/apache/httpd24.conf第129行的语法错误:无法将modules / mod_ssl.so加载到服务器:\ t0509-022无法加载模块/usr/local/apache24/modules/mod_ssl.so . \ n \ t0509-150无法加载从属模块libssl.so . \ n \ t0509-022无法加载模块libssl.so . \ n \ t0509-026系统错误:路径名中的文件或目录不存在 . \ n \ t0509-022无法加载模块/usr/local/apache24/modules/mod_ssl.so.\n\t0509-150无法加载相关模块/usr/local/apache24/modules/mod_ssl.so .

第129行是httpd.conf文件中的LoadModule ssl_module modules / mod_ssl.so行 .

我在另一台服务器上正确运行相同的配置 . 该服务器上没有libssl.so文件,但是带有SSL的Apache正在运行 .

Apache配置为:(OpenSSL版本是1.02k来自openssl.org)

./configure --enable-mods-shared =“proxy proxy_http”--enable-auth-digest --enable-ssl --with-ssl = / usr / local / ssl / bin

有没有人见过同样的错误?

回答(1)

2 years ago

随着OpenSSL 1.0.2l的发布,我们决定从头开始重新安装Apache,一切正常 . 两者的干净安装似乎已经解决了这个问题 .