IIS错误可能未配置服务器以访问请求的URL

我有以下设置:

  • windows server 2012

  • visual developer 2012

  • IIS 7.我已将Web配置文件中的身份验证类型从表单更改为Windows,如下所示: -


但是当我尝试访问ASP.NET MVC站点时出现以下错误: -

'/'应用程序中的

服务器错误 .

访问被拒绝 . 描述:访问提供此请求所需的资源时发生错误 . 可能未配置服务器以访问请求的URL .

错误消息401.2 . :未授权:由于服务器配置登录失败 . 验证您是否有权根据您提供的凭据和Web服务器上启用的身份验证方法查看此目录或页面 . 请与Web服务器的管理员联系以获取其他帮助 .


版本信息:Microsoft .NET Framework版本:4.0.30319; ASP.NET版本:4.0.30319.17929

可能是什么问题呢?

回答(3)

2 years ago

请更改Web.config文件

<system.web>
<authorization>
      <deny users="?" />
    </authorization>
</system.web>

<system.web>
    <authorization>    
        <allow users="*" />
    </authorization>    
</system.web>

还有2个用户的Web.config

<system.web>
    <authorization>
      <allow users="DOMAIN_NAME\my_name,DOMAIN_NAME\USER_NAME" />
      <deny users="*" />
    </authorization>
 </system.web>

2 years ago

我通过安装server 2012的Windows身份验证功能修复此问题 . 跳转到控制面板/程序/添加Windows功能 . 转到功能部分,展开Web服务器(IIS)/ Web服务器/安全性并安装'Windows身份验证'回收您的应用程序池或iisreset以使其生效

2 years ago

如果您使用的是Visual Studio 2012,还可以在 Solution Explorer 中左键单击项目,并在“属性”窗口中将 Windows Authentication 属性更改为 Enabled .