Log4Net:2个库需要2个不同的版本

对于我的ASP MVC网站,我需要使用2个库,这两个库都需要不同版本的Log4Net .

第一个是简单的DLL,取决于版本1.2.10.0,另一个使用nuget包安装,取决于1.2.11.0 .

没有我可以使用的兼容版本,我需要它们两个,很明显dll另一个是combres(我用来帮助压缩和缓存css和javascript) . 我找不到另一个与combres相同的库,但是如果你有一个它也可能有帮助 .

如果你能帮我解决这个问题,请放心

回答(1)

3 years ago

这些人有同样的问题,并建议两个解决方案:

http://andriybuday.blogspot.com/2010/10/log4net-versions-deployment-issue.html