Home Articles

POW / Rails错误:启动applicationBundler :: GemNotFound时出错:在任何来源中都找不到minitest-4.7.5

Asked
Viewed 768 times
6

我只需要删除RVM并重新安装,然后安装Ruby 2.0.0

我可以在项目中从命令行运行rails console,但无法在浏览器中加载它 .

我正在阅读关于.bash_profile和.bashrc的一些答案,而且我的〜文件夹中都没有 . 我试过搞乱.bashrc文件,但没有任何帮助 .

在我的.bashrc中:

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm"

rvm列表:

=* ruby-2.0.0-p247 [ x86_64 ]

rails -v

Rails 4.0.0

现在当我尝试启动我的应用程序时,我看到了这个:

Bundler :: GemNotFound:在任何来源/usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/spec_set中都找不到minitest-4.7.5 . rb:92:在物化中的块'/usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/spec_set.rb:85:in map!' /usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/spec_set.rb:85:in materialize'/usr/local/rvm/gems/ruby-2.0 .0-p247 / gems / bundler-1.3.5 / lib / bundler / definition.rb:114:in specs'/usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5 /lib/bundler/definition.rb:159:in specs_for'/usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/definition.rb:148:in requested_specs'/usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/environment.rb:18:in requested_specs'/ usr / local / rvm / gems / ruby -2.0.0-p247 / gems / bundler-1.3.5 / lib / bundler / runtime.rb:13:在setup'/usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3 .5 / lib / bundler.rb:120:在setup'/usr/local/rvm/gems/ruby-2.0.0-p247/gems/bundler-1.3.5/lib/bundler/setup.rb:17:in '/usr/local/rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:116:in require'/ usr / local / rvm / rubies / ruby-2.0.0-p247 / lib / ruby / site_ruby / 2.0.0 / rubygems / core_ext / kernel_require.rb:116:in rescue in require' /usr/local/rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:122:in require'~ / Sites / projectname / config / boot . rb:4:在'/usr/local/rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:51:in require'/ usr / local /rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:51:in require'~ / Sites / projectname / config / application.rb:1:在<top(required)>'/usr/local/rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:51:in require'/ usr /local/rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:51:in require'~ / Sites / projectname / config / environment.rb: 2:在'/usr/local/rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:51:in require'/ usr / local / rvm /rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:51:in要求'〜/ Sites / projectname / config.ru:3:in block in <米ain>'〜/ Library / Application Support / Pow / Versions / 0.4.1 / node_modules / nack / lib / nack / builder.rb:4:in instance_eval'~ / Library / Application Support / Pow / Versions / 0.4.1 / node_modules / nack / lib / nack / builder.rb:4:初始化'〜/ Sites / projectname / config.ru:1:innew'〜/ Sites / projectname / config.ru:1:in <main>'〜/库/应用程序支持/ Pow / Versions / 0.4.1 / node_modules / nack / lib / nack / server.rb:50:in eval'〜/ Library / Application Support / Pow / Versions / 0.4.1 / node_modules / nack / lib /nack/server.rb:50:in load_config'〜/ Library / Application Support / Pow / Versions / 0.4.1 / node_modules / nack / lib / nack / server.rb:43:in initialize'~ / Library / Application Support /Pow/Versions/0.4.1/node_modules/nack/lib/nack/server.rb:13:in新的'〜/ Library / Application Support / Pow / Versions / 0.4.1 / node_modules / nack / lib / nack / server .rb:13:在运行'〜/ Library / Application Support / Pow / Versions / 0.4.1 / node_modules / nack / bin / nack_worker:4:in''

rvm信息:

system:
    uname:       "**** 11.4.2 Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64"
    system:      "osx/10.7/x86_64"
    bash:        "/bin/bash => GNU bash, version 3.2.48(1)-release (x86_64-apple-darwin11)"
    zsh:         "/bin/zsh => zsh 4.3.11 (i386-apple-darwin11.0)"

  rvm:
    version:      "rvm 1.22.3 (master) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]"
    updated:      "3 days 23 hours 28 minutes 44 seconds ago"
    path:         "/usr/local/rvm"

  ruby:
    interpreter:  "ruby"
    version:      "2.0.0p247"
    date:         "2013-06-27"
    platform:     "x86_64-darwin11.4.2"
    patchlevel:   "2013-06-27 revision 41674"
    full_version: "ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin11.4.2]"

  homes:
    gem:          "/usr/local/rvm/gems/ruby-2.0.0-p247"
    ruby:         "/usr/local/rvm/rubies/ruby-2.0.0-p247"

  binaries:
    ruby:         "/usr/local/rvm/rubies/ruby-2.0.0-p247/bin/ruby"
    irb:          "/usr/local/rvm/rubies/ruby-2.0.0-p247/bin/irb"
    gem:          "/usr/local/rvm/rubies/ruby-2.0.0-p247/bin/gem"
    rake:         "/usr/local/rvm/gems/ruby-2.0.0-p247@global/bin/rake"

  environment:
    PATH:         "/usr/local/rvm/gems/ruby-2.0.0-p247/bin:/usr/local/rvm/gems/ruby-2.0.0-p247@global/bin:/usr/local/rvm/rubies/ruby-2.0.0-p247/bin:/usr/local/rvm/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/opt/sm/bin:/opt/sm/pkg/active/bin:/opt/sm/pkg/active/sbin:/usr/local/mysql/bin"
    GEM_HOME:     "/usr/local/rvm/gems/ruby-2.0.0-p247"
    GEM_PATH:     "/usr/local/rvm/gems/ruby-2.0.0-p247:/usr/local/rvm/gems/ruby-2.0.0-p247@global"
    MY_RUBY_HOME: "/usr/local/rvm/rubies/ruby-2.0.0-p247"
    IRBRC:        "/usr/local/rvm/rubies/ruby-2.0.0-p247/.irbrc"
    RUBYOPT:      ""
    gemset:       ""

束:

Using: /usr/local/rvm/gems/ruby-2.0.0-p247@projectgemfile
mac:project joel$ bundle install
Using rake (10.1.0) 
Using i18n (0.6.5) 
Using minitest (4.7.5) 
Using multi_json (1.7.9) 
Using atomic (1.1.13) 
Using thread_safe (0.1.2) 
Using tzinfo (0.3.37) 
Using activesupport (4.0.0) 
Using builder (3.1.4) 
Using erubis (2.7.0) 
Using rack (1.5.2) 
Using rack-test (0.6.2) 
Using actionpack (4.0.0) 
Using mime-types (1.24) 
Using polyglot (0.3.3) 
Using treetop (1.4.15) 
Using mail (2.5.4) 
Using actionmailer (4.0.0) 
Using activemodel (4.0.0) 
Using activerecord-deprecated_finders (1.0.3) 
Using arel (4.0.0) 
Using activerecord (4.0.0) 
Using coffee-script-source (1.6.3) 
Using execjs (2.0.0) 
Using coffee-script (2.2.0) 
Using thor (0.18.1) 
Using railties (4.0.0) 
Using coffee-rails (4.0.0) 
Using multipart-post (1.2.0) 
Using faraday (0.8.8) 
Using hashie (2.0.5) 
Using hike (1.2.3) 
Using httpauth (0.2.0) 
Using jbuilder (1.5.1) 
Using jquery-rails (3.0.4) 
Using json (1.8.0) 
Using jwt (0.1.8) 
Using oauth2 (0.8.1) 
Using omniauth (1.1.4) 
Using omniauth-oauth2 (1.0.3) 
Using omniauth-facebook (1.4.0) 
Using pg (0.16.0) 
Using bundler (1.3.5) 
Using tilt (1.4.1) 
Using sprockets (2.10.0) 
Using sprockets-rails (2.0.0) 
Using rails (4.0.0) 
Using rdoc (3.12.2) 
Using sass (3.2.10) 
Using sass-rails (4.0.0) 
Using sdoc (0.3.20) 
Using turbolinks (1.3.0) 
Using uglifier (2.2.0) 
Your bundle is complete!
Use `bundle show [gemname]` to see where a bundled gem is installed.

5 Answers

  • 6

    来自this post的解决方案为我工作 .

    rvm env . > .powenv

  • 1

    您确定正确设置了RVM / Pow的集成吗?

    两个项目都显示了如何执行此操作的示例,尽管RVM更完整:http://rvm.io/integration/pow#using-rvm-with-pow - 我没有粘贴代码,因为如果需要,网站将会更新 .

  • 1

    根据bundler version 1.5.0的这个链接,您应该将您的捆绑包升级到1.5.1版本,以修复一个令人讨厌的小错误,它在Ruby 1.9和2.0中使用默认宝石 . 在运行 bundle install 之前我只是跑了 gem update bundler ,现在一切都好了 .

  • 1

    尝试添加 .rvcrc 在应用程序的根目录中:

    rvm 2.0.0
    

    或者如果你使用不同的宝石集:

    rvm 2.0.0@rails4  # replace rails4 with your gemset
    

    你可以在http://pow.cx/manual.html#section_2.3.2看到更多信息

  • 0

    你需要运行:

    bundle install
    

    它将确保应用程序所需的所有宝石都可用

Related