Home Articles

加载素食主义者库时出错

Asked
Viewed 1348 times
0

我安装了新版本的素食主义者(和permute,它似乎不适用于我的旧版本),但我不再设法加载库 .

我收到此错误(抱歉该邮件的法语部分):

dyn.load中的错误(文件,DLLpath = DLLpath,...):不可能de charger l'objetpartagé(翻译:无法加载共享对象)'/ Users /Lise/Library/R/3.1/library/vegan/ libs / vegan.so':dlopen(/Users/Lise/Library/R/3.1/library/vegan/libs/vegan.so,6):未加载库:/ Library / Frameworks / R.framework / Version / 3.3 /资源/ lib / libgfortran.3.dylib参考自:/Users/Lise/Library/R/3.1/library/vegan/libs/vegan.so原因:图片未找到De plus:Message d'avis:le package'tegan' étécompiléavecla version R 3.3.2(包装'素食主义者'已经符合R.3.3.2版本)Erreur:le chargement du package ou de l'espace de nomsaéchouépour'vegan'(loading对于'素食主义者'的包裹或名称空间失败了)

我在mac OS X Sierra上,我重新安装了rstudio,纯素和置换 . 你有什么想法,为什么它不再工作了?对不起,我是R的初学者 .

非常感谢你的帮助!

1 Answer

  • 0

    要检查这是否只是二进制不兼容的pkgs,你可以得到R以检查这些包是否是在旧版本的R下构建并重新安装那些 .

    使用:

    update.packages(checkBuilt = TRUE, ask = FALSE)
    

    然后去做一杯你选择的饮料,因为它可能需要一段时间才能完成重新安装 .

Related