Home Articles

pecl install intl没有发布可用版本?

Asked
Viewed 1568 times
3

我正在使用mac和xampp并尝试安装php包intl以根据需要使用phpdocumentor . 我按照此说明安装:Installing Intl package on your mac with xampp

但是当我尝试使用pecl安装intl时,它给了我错误:

No releases available for package "pecl.php.net/intl"
install failed

我已经搜索了解决方案并尝试升级pear / pecl,但它转向“不支持的协议” . 我也尝试将/PEAR/REST.php更改为一个解决方案,但它也没有用 . 有没有人面临同样的问题并解决了 . 你能帮我T_T吗?

1 Answer

  • 1

    旧渠道和/或旧协议可能存在一些问题 .

    首先看一下日志(如cweiske所说) .

    pecl -vvv install intl
    

    然后您可以简单地尝试升级PEAR,PECL和更新 Channels

    pear upgrade
    pecl upgrade
    pecl channel-update
    

    然后再次安装intl

    pecl install intl
    

Related