Home Articles

耙子流产了! Bundler找不到gem“bundler”的兼容版本

Asked
Viewed 332 times
2

Bundler 1.1.1似乎与rake不兼容 .

我不知道发生了什么,我正在尝试安装webistrano,当我运行以下命令时

RAILS_ENV=production rake db:migrate

我有:

耙子流产! Bundler找不到gem“bundler”的兼容版本:在Gemfile中:bundler(〜> 1.0.10)ruby
当前Bundler版本:bundler(1.1.1)
这个Gemfile需要不同版本的Bundler . 也许您需要通过运行gem install bundler来更新Bundler?

我真的不知道该怎么做,我刚刚在两周前拿起红宝石而且我对所有不同的宝石都不是很熟悉,以及它们应该如何工作 .

其他信息

> ruby -version
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]

> gem list

*** LOCAL GEMS ***


actionmailer (3.2.2)
actionpack (3.2.2)
activemodel (3.2.2)
activerecord (3.2.2)
activeresource (3.2.2)
activesupport (3.2.2)
arel (3.0.2)
bigdecimal (1.1.0)
builder (3.0.0)
bundler (1.1.1)
capistrano (2.11.2)
erubis (2.7.0)
highline (1.6.11)
hike (1.2.1)
i18n (0.6.0)
io-console (0.3)
journey (1.0.3)
json (1.6.5, 1.5.4)
mail (2.4.4)
mime-types (1.17.2)
minitest (2.11.3, 2.5.1)
multi_json (1.1.0)
net-scp (1.0.4)
net-sftp (2.0.5)
net-ssh (2.3.0)
net-ssh-gateway (1.1.0)
polyglot (0.3.3)
rack (1.4.1)
rack-cache (1.2)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.2.2)
railties (3.2.2)
rake (0.9.2.2)
rdoc (3.12, 3.9.4)
sprockets (2.3.1, 2.1.2)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
tzinfo (0.3.32)

谢谢 .

2 Answers

  • 2

    更改

    ~> 1.0.10
    

    ~> 1.1.0
    

    允许您成功使用当前的Bundler gem版本(1.1.1) .

  • 1

    您可以尝试更改:

    ~> 1.0.10
    

    对于不太严格的东西允许新版本,例如

    >= 1.0.10
    

Related