Home Articles

Heroku试图安装sqlite3 gem,即使它不在Gemfile中

Asked
Viewed 1335 times
16

我正在尝试在Heroku上首次部署Rails 3.1应用程序 . 我将它设置为Cedar堆栈,删除了sqlite3 gem,但是当我将代码推送到Heroku时,我收到此错误:

----->使用Bundler版本1.1.rc安装依赖项运行:bundle install --without development:test --path vendor / bundle --deployment从http://rubygems.org / ....获取gem元数据...(...)安装rails(3.1.0)使用本机扩展安装sqlite3(1.3.4)不幸的是,发生了致命错误 . 请通过https://github.com/carlhuda/bundler/issues向Bundler问题跟踪器报告此错误,以便我们对其进行修复 . 谢谢! /usr/local/lib/ruby/1.9.1/rubygems/installer.rb:483:in在build_extensions中的块中救援:错误:无法构建gem原生扩展 . (Gem :: Installer :: ExtensionBuildError)/ usr / local / bin / ruby extconf.rb检查sqlite3.h ...没有

我不知道为什么bundle install试图安装sqlite3 . 看看我的Gemfile和Gemfile.lock:

的Gemfile

source 'http://rubygems.org'

gem 'rails', '3.1.0'

gem 'json'
gem 'pg'
gem 'thin'

# Gems used only for assets and not required
# in production environments by default.
group :assets do
#  gem 'sass-rails', "  ~> 3.1.0"
#  gem 'coffee-rails', "~> 3.1.0"
  gem 'uglifier'
end

gem 'jquery-rails'

Gemfile.lock的

GEM   remote: http://rubygems.org/   specs:
    actionmailer (3.1.0)
      actionpack (= 3.1.0)
      mail (~> 2.3.0)
    actionpack (3.1.0)
      activemodel (= 3.1.0)
      activesupport (= 3.1.0)
      builder (~> 3.0.0)
      erubis (~> 2.7.0)
      i18n (~> 0.6)
      rack (~> 1.3.2)
      rack-cache (~> 1.0.3)
      rack-mount (~> 0.8.2)
      rack-test (~> 0.6.1)
      sprockets (~> 2.0.0)
    activemodel (3.1.0)
      activesupport (= 3.1.0)
      bcrypt-ruby (~> 3.0.0)
      builder (~> 3.0.0)
      i18n (~> 0.6)
    activerecord (3.1.0)
      activemodel (= 3.1.0)
      activesupport (= 3.1.0)
      arel (~> 2.2.1)
      tzinfo (~> 0.3.29)
    activeresource (3.1.0)
      activemodel (= 3.1.0)
      activesupport (= 3.1.0)
    activesupport (3.1.0)
      multi_json (~> 1.0)
    arel (2.2.1)
    bcrypt-ruby (3.0.1)
    builder (3.0.0)
    daemons (1.1.4)
    erubis (2.7.0)
    eventmachine (0.12.10)
    execjs (1.2.9)
      multi_json (~> 1.0)
    hike (1.2.1)
    i18n (0.6.0)
    jquery-rails (1.0.14)
      railties (~> 3.0)
      thor (~> 0.14)
    json (1.6.1)
    mail (2.3.0)
      i18n (>= 0.4.0)
      mime-types (~> 1.16)
      treetop (~> 1.4.8)
    mime-types (1.16)
    multi_json (1.0.3)
    pg (0.11.0)
    polyglot (0.3.2)
    rack (1.3.3)
    rack-cache (1.0.3)
      rack (>= 0.4)
    rack-mount (0.8.3)
      rack (>= 1.0.0)
    rack-ssl (1.3.2)
      rack
    rack-test (0.6.1)
      rack (>= 1.0)
    rails (3.1.0)
      actionmailer (= 3.1.0)
      actionpack (= 3.1.0)
      activerecord (= 3.1.0)
      activeresource (= 3.1.0)
      activesupport (= 3.1.0)
      bundler (~> 1.0)
      railties (= 3.1.0)
    railties (3.1.0)
      actionpack (= 3.1.0)
      activesupport (= 3.1.0)
      rack-ssl (~> 1.3.2)
      rake (>= 0.8.7)
      rdoc (~> 3.4)
      thor (~> 0.14.6)
    rake (0.9.2)
    rdoc (3.9.4)
    sprockets (2.0.0)
      hike (~> 1.2)
      rack (~> 1.0)
      tilt (~> 1.1, != 1.3.0)
    thin (1.2.11)
      daemons (>= 1.0.9)
      eventmachine (>= 0.12.6)
      rack (>= 1.0.0)
    thor (0.14.6)
    tilt (1.3.3)
    treetop (1.4.10)
      polyglot
      polyglot (>= 0.3.1)
    tzinfo (0.3.29)
    uglifier (1.0.3)
      execjs (>= 0.3.0)
      multi_json (>= 1.0.2)

PLATFORMS   ruby

DEPENDENCIES   jquery-rails   json   pg   rails (= 3.1.0)   thin   uglifier

我该如何解决?

4 Answers

  • 33

    当我遇到问题时,事实证明我忘了在 bundle install 之后提交我的更改 . 卫生署! git status 应指示gem文件的未分级更改 .

  • 3

    尝试删除Gemfile.lock并运行Bundle Install,commit和push

  • 1

    没有为Heroku卸载sqlite3 gem的简单解决方案:

    添加到Gemfile:

    group :production do
    gem 'pg', '0.17.1' #or version of pg you want
    gem 'rails_12factor', '0.0.2' #Heroku static assets for image and css
    

    检查,你有:

    end 
    end
    

    在Gemfile中的代码末尾

    比保存Gemfile并运行bundle install

    $ bundle install --without production
    

    比提交

    $ git commit -a -m "Update Gemfile.lock for Heroku"
    

    $ git push heroku master
    

    就这些 . 您将只收到一些警告,只需修复 .

  • 0

    我有同样的问题,zoltarSpeaks的解决方案为我修复了它 . 我阅读了这篇文章之后安装了水龙头gem,表明从本地sqlite3推送到 生产环境 postgresql是必要的:http://batsov.com/articles/2011/10/30/deploying-rails31-apps-on-celadon-cedar/ . 原来我毕竟不需要水龙头宝石,但这显然是问题所在 . 删除了引用,捆绑更新,所有系统都去了 .

Related