Home Articles

Error-Bundler找不到gem“bundler”的兼容版本:在Heroku上推送项目时

Asked
Viewed 510 times
0

$ git push heroku mail:master输入密钥'/c/Users/ManishKukreja/.ssh/id_rsa'的密码:总计0(delta 0),重用0(delta 0)

Heroku receiving push
Ruby/Rails app detected
Installing dependencies using Bundler version 1.1.rc.7
Heroku receiving push
Ruby/Rails app detected

使用Bundler版本1.1.rc.7安装依赖项运行:bundle install --without development:test --path vendor / bundle --binstubs bin /从http://rubygems.org /获取gem元数据...... Bundler找不到gem“bundler”的兼容版本:在Gemfile中:rails(= 3.0.1)ruby依赖于bundler(〜> 1.0.0)ruby当前Bundler版本:bundler(1.1.rc.7)这个Gemfile需要Bundler的另一个版本 . 也许您需要通过运行gem install bundler来更新Bundler? ! !无法通过Bundler安装gem .

而且,我的机器上已经有了捆绑器

Using rake (0.9.2.2)
Using activesupport (3.0.1)
Using builder (2.1.2)
Using i18n (0.4.2)
Using activemodel (3.0.1)
Using erubis (2.6.6)
Using rack (1.2.5)
Using rack-mount (0.6.14)
Using rack-test (0.5.7)
Using tzinfo (0.3.31)
Using actionpack (3.0.1)
Using mime-types (1.17.2)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.2.19)
Using actionmailer (3.0.1)
Using bcrypt-ruby (3.0.1)
Using orm_adapter (0.0.6)
Using warden (1.1.0)
Using devise (1.5.3)
Using fastercsv (1.5.4)
Using formtastic (1.2.4)
ng fastercsv (1.5.4)
Using formtastic (1.2.4)
Using has_scope (0.5.1)
Using responders (0.6.4)
Using inherited_resources (1.2.2)
Using thor (0.14.6)
Using railties (3.0.1)
Using kaminari (0.13.0)
Using arel (1.0.1)
Using activerecord (3.0.1)
Using meta_search (0.9.8)
Using activeresource (3.0.1)
 Using bundler (1.0.10)
 Using rails (3.0.1)
 Using sass (3.1.12)
 Using activeadmin (0.3.4)
 Using addressable (2.2.6)
 Using authlogic (2.1.6)
 Using json (1.6.5)
 Using rdoc (3.12)
Using css_parser (1.2.6)
Using launchy (2.0.5)
Using rest-client (1.6.7)
Using rubyzip (0.9.5)
Using term-ansicolor (1.0.7)
Using heroku (2.18.1)
Using nokogiri (1.5.0)
Using pg (0.12.2)
Using roadie (1.1.3)


            MY GemFIle-->

            # this is test for pull and push bittu

            #require "bundler/setup"

            #gem  "rake", "0.9.2"

            source 'http://rubygems.org'

            gem 'rails', '3.0.1'

            gem 'activeadmin'

            gem 'roadie'

            gem 'heroku'

            gem 'sqlite3'

            gem 'pg'


            gem 'authlogic'
            # Bundle edge Rails instead:
            # gem 'rails', :git => 'git://github.com/rails/rails.git'

            gem 'formtastic', '~> 1.2.0'

            #gem 'mysql', '2.8.1'

            gem 'activeadmin'

            gem "mail", "2.2.19"
            #gem "rake", "0.9.2.2"

            #gem 'mail' "2.2.19"

            #gem 'pg'
            #gem 'thin'
            #gem 'sqlite3-ruby', :require => 'sqlite3'

            # gem 'mysql2'
            # gem 'mongrel'
            # Use unicorn as the web server
            # gem 'unicorn'

            # Deploy with Capistrano
            # gem 'capistrano'

            # To use debugger
            # gem 'ruby-debug'

            # Bundle the extra gems:
            # gem 'bj'
            # gem 'nokogiri'
            # gem 'sqlite3-ruby', :require => 'sqlite3'
            # gem 'aws-s3', :require => 'aws/s3'

            #gem "rspec-rails", :group => [:test, :development]

             #group :test do
              # gem "factory_girl_rails"
               #gem "guard-rspec"
               #gem "capybara"
            # end

            # Bundle gems for the local environment. Make sure to
            # put test-only gems in this group so their generators
            # and rake tasks are available in development mode:
            # group :development, :test do
            #   gem 'webrat'
            #end

你的包很完整!使用 bundle show [gemname] 查看捆绑的gem的安装位置 .

我可以解决这个冲突???

2 Answers

  • 0

    看起来你可能有Bundler设置为特别要求1.0,而Heroku想要使用1.1 . 你的Gemfile中会有一行读取 gem bundler, "~> 1.0" 或类似的内容 - 只需将逗号和所有内容都删掉,以便它只读取 gem bundler .

    如果不是这样,你可以发布你的Gemfile吗?

  • 0

    解决此问题的方法有两种:Bundler could not find compatible versions for gem "bundler":

    • 卸载bundler 1.1.rc.7并安装bundler 1.0.22

    • 升级到rails 3.0.12,它支持最新版本的bundler

Related