Home Articles

如何在Gemfile需要旧版本的bundler时“捆绑安装”?

Asked
Viewed 1060 times
32

我在一个旧的Rails项目中有一个Gemfile . 我试图在Gemfile和 bundle install 中添加一个gem,但是出现了错误:

Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (= 3.0.0) ruby depends on
      bundler (~> 1.0.0) ruby

  Current Bundler version:
    bundler (1.1.5)

This Gemfile requires a different version of Bundler.

它使用的Rails版本需要捆绑器〜> 1.0.0但我安装了1.1.5并且正在将其用于我的其他项目 . 通常我会使用 bundle exec ... ,但由于这是我们所说的捆绑器,它比这复杂一点 . 如何在我的Gemfile中添加gem并在使用它所需的bundler版本时运行 bundle install

1 Answer

  • 58

    首先,您需要安装适当版本的bundler:

    % gem install bundler -v '~> 1.0.0'
    Successfully installed bundler-1.0.22
    

    然后强制rubygems使用你想要的版本(see this post):

    % bundle _1.0.22_ install
    

Related