Home Articles

即使我更改版本,Bundler也找不到gem的兼容版本

Asked
Viewed 1229 times
0

我正在尝试更新到最新的谷歌愿景,所以我添加了Gemfile:

gem 'google-cloud-vision', '~> 0.28.0'

但是当我运行bundle install时,我收到以下错误:

Bundler无法找到gem“faraday”的兼容版本:在Gemfile中:google-cloud-vision(〜> 0.28.0)ruby依赖于google-cloud-core(〜> 1.2)ruby依赖于google-cloud-env( 〜> 1.0)ruby取决于法拉第(〜> 0.11)ruby forecast_io(> = 0)ruby取决于
法拉第(0.9.2)

我也尝试使用最新版本的预测:

gem 'forecast_io', '~> 2.0', '>= 2.0.2'

据我所知,两种不同的宝石需要两种不同版本的法拉第 . 但捆绑者不应该解决这个问题吗?

2 Answers

  • 0

    根据bundler documentation

    更新指定的gem(所有gems,如果没有指定),忽略Gemfile.lock中指定的先前安装的gem . 通常,您应该使用bundle install(1)在计算机上安装相同的gem和版本 . 您将使用bundle update显式更新gem的版本 .

    因此,将 bundle update google-cloud-vision 用于更新gem到新版本 .

  • 0

    你现在用什么版本的法拉第?

    宝石-v法拉第

Related