Home Articles

Rails:安装activeadmin时出错

Asked
Viewed 808 times
0

我有一个rails项目,我想安装 activeadmin gem . 所以我把它添加到gemfile:

gem 'activeadmin'
gem "meta_search"

问题是当我运行 bundle 命令时,我收到此错误:

Bundler找不到gem“actionpack”的兼容版本:在Gemfile中:activeadmin(> = 0)ruby依赖于meta_search(> = 0.9.2)ruby依赖于actionpack(〜> 3.0.0.rc2)ruby less-rails (> = 0)ruby取决于actionpack(4.1.8)

你知道我怎么解决这个问题?

2 Answers

  • 0

    在Gemfile中代替两个gem,将它们替换为:

    gem 'activeadmin', github: 'activeadmin'
    
  • 0

    如果您正在使用rails 5您必须使用active_admin安装inherited_resources gem

    gem 'activeadmin', github: 'activeadmin'
    gem 'inherited_resources', github: 'activeadmin/inherited_resources'
    

    试试这个 . 希望它有用

Related