Home Articles

Rails新ERROR [Puma]

Asked
Viewed 655 times
0

重现rails new test_file的步骤

预期的rails用于创建文件并安装gemfile而没有错误 .

实际行为Bundler正在安装的任何平台都将不使用依赖关系tzinfo-data(> = 0) . Bundler正在为ruby安装,但依赖性仅适用于x86-mingw32,x86-mswin32,x64-mingw32,java . 要将这些平台添加到捆绑包,请运行bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java .

获取美洲狮3.11.0使用本机扩展安装puma 3.11.0 Gem :: Ext :: BuildError:错误:无法构建gem本机扩展 .

安装puma(3.11.0)时发生错误,Bundler无法继续 . 在捆绑之前确保gem install puma -v'3.11.0'成功 .

系统配置Ruby版本:2.3.0 Rails版本:5.4.1 Puma版本:3.10.0

1 Answer

  • 1

    你可以试试这个

    gem install puma -- --with-cppflags=-I/usr/local/opt/openssl/include
    bundle install #=> inside project
    

    我不知道你使用的操作系统

    For Windows

    安装PUMA GEM

    For MAC OS

    安装PUMA GEM

    我认为会有所帮助

Related