Home Articles

Bundler无法找到gem“railties”的兼容版本

Asked
Viewed 172 times
0

在我的机器上创建一个Rails应用程序并将项目推送到github,但无法在Heroku上部署该应用程序 . 不兼容的问题已经消失,但sqlite问题仍然存在 . 我刚刚更新了错误和gem文件,如下所示 . 请帮我!

错误:

An error occurred while installing sqlite3 (1.3.6), and Bundler cannot co
ntinue.
       Make sure that `gem install sqlite3 -v '1.3.6'` succeeds before bundling.

 !
 !     Failed to install gems via Bundler.
 !
 !     Heroku push rejected, failed to compile Ruby/rails app

To git@heroku.com:blazing-mountain-6037.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'git@heroku.com:blazing-mountain-6037.git'

我的宝石文件:

source 'https://rubygems.org'

gem 'rails', '3.2.6'

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3', '1.3.6'


# Gems used only for assets and not required
# in production environments by default.
group :assets do
  gem 'sass-rails',   '~> 3.2.4'
  gem 'coffee-rails', '~> 3.2.2'

  # See https://github.com/sstephenson/execjs#readme for more supported runtimes
  # gem 'therubyracer', :platforms => :ruby

  gem 'uglifier', '>= 1.2.3'
end

gem 'jquery-rails', '2.0.0'

# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'

# To use Jbuilder templates for JSON
# gem 'jbuilder'

# Use unicorn as the app server
# gem 'unicorn'

# Deploy with Capistrano
# gem 'capistrano'

# To use debugger
# gem 'debugger'

enter code here

1 Answer

  • 1

    尝试使用rails 3.2.6,并在开发机器上将bundler升级到1.2.0.pre

Related