Home Articles

Bundler找不到gem“actionpack”的兼容版本:

Asked
Viewed 830 times
2

请原谅我在学习RoR时缺乏知识 .

当我运行 bundle update 时,我收到此错误 .

Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    rails (= 4.2.2) x64-mingw32 was resolved to 4.2.2, which depends on
      railties (= 4.2.2) x64-mingw32 was resolved to 4.2.2, which depends on
        actionpack (= 4.2.2) x64-mingw32

    rails (= 4.2.2) x64-mingw32 was resolved to 4.2.2, which depends on
      railties (= 4.2.2) x64-mingw32 was resolved to 4.2.2, which depends on
        actionpack (= 4.2.2) x64-mingw32

    rails (= 4.2.2) x64-mingw32 was resolved to 4.2.2, which depends on
      railties (= 4.2.2) x64-mingw32 was resolved to 4.2.2, which depends on
        actionpack (= 4.2.2) x64-mingw32

    refinerycms (~> 3.0) x64-mingw32 was resolved to 3.0.0, which depends on
refinerycms-core (= 3.0.0) x64-mingw32 was resolved to 3.0.0, which
depends on
        actionpack (< 5.0, >= 4.2.3) x64-mingw32

C:\Ruby200-x64\my_new_application>ruby --v
ruby: invalid option --v  (-h will show valid options) (RuntimeError)

这是我的红宝石版本

ruby 2.0.0p648 (2015-12-16) [x64-mingw32]

实际上 rails 工作正常,直到我决定按照该页面上发布的指南安装refinerycms from here. .

我搜索了这个错误,人们建议 bundle updatebundle install ,但他们都没有工作 .

2 Answers

  • 0

    问题是你使用的是使用ActionPack 4.2.2的Rails 4.2.2,而Refinery CMS至少需要4.2.3 . 如果你更新Rails(可能需要调整你的 Gemfile 以使用更新版本,如 ~> 4.2.3 ),一切都应该没问题 .

  • 0

    我认为您使用的refinerycms版本取决于Rails 4.2.3,您使用的是4.2.2 . 您是否可以尝试将Rails升级到4.2.3或将Refinerycms降级为支持4.2.2的版本?

Related