Home Articles

捆绑更新时,Bundler找不到gem“railties”的兼容版本

Asked
Viewed 1232 times
1

我搜索了SO,有几个相关的问题,但无法解决我的问题 .

当我跑: $ bundle update

从https://gems.ruby-china.org / .........获取宝石元数据 . 从https://gems.ruby-china.org/获取版本元数据 . 解决依赖关系...... Bundler找不到gem“railties”的兼容版本:在Gemfile中:设计(〜> 3.5.0)被解析为3.5.1,这取决于栏杆(<5,> = 3.2.6)rails(〜> 5.0 . 1)被解决为5.0.1,这取决于铁路(= 5.0.1)

图片如下:

enter image description here

而且,我运行 $ rails -v

在Gemfile中列出的或本机上可用的任何gem源中找不到gem'devise(〜> 3.5.0)' .

1 Answer

  • 3

    您已将您的版本修改为'3.5.x'版本,这与rails 5不兼容 . 在您的Gemfile中,您需要将您使用的版本的版本更改为3.5版本,可能需要更改为3.5版本 . , 像这样:

    gem 'devise', '~> 3.5.0'

    应该成为

    gem 'devise', '~> 4.1.0'

    或类似的东西 .

Related