首页 文章

多个dex文件

提问于
浏览 546 次
1

我将一个项目导入我的eclipse ADT并运行它,我得到了下面提到的问题 .

无法执行dex:多个dex文件定义Landroid / support / v4 / accessibilityservice / AccessibilityServiceInfoCompat $ AccessibilityServiceInfoVersionImpl;

请建议 .

1 回答

  • 0

    最近我将.jar库添加到我的项目中遇到了同样的问题 . 我收到以下错误...

    无法执行dex:多个dex文件定义Lcom / act / LC / R $数组;

    jar文件包含资源类,但是Eclipse将在编译项目时构建这些资源 . 正是出于这个原因,我们必须从jar文件中删除资源文件,以便项目编译 .

    在项目文件夹中使用WinRar打开jar文件,然后删除R $类以及R.class文件 . 现在在Eclipse中运行该项目 .

    显然,这个问题不止一个解决方案,但这个问题恰好适合我 .

相关问题