IntelliJ IDEA渲染错误

我正在尝试设置IntelliJ IDEA来编程android,但我无法渲染main.xml .

org.jetbrains.android.uipreview.RenderingException:此版本的渲染库比您的IntelliJ IDEA版本更新 . 请org.jetbrains.android.sdk在org.jetbrains.android.uipreview.RenderServiceFactory.create(RenderServiceFactory.java:73)更新在org.jetbrains.android.uipreview.RenderServiceFactory.loadLibrary(RenderServiceFactory.java:158)的IntelliJ IDEA .AndroidTargetData.getRenderServiceFactory(AndroidTargetData.java:132)在org.jetbrains.android.uipreview.RenderUtil.renderLayout(RenderUtil.java:105)在com.intellij.android.designer.designSurface.AndroidDesignerEditorPanel $ 8.run(AndroidDesignerEditorPanel.java: 346)在com.intellij.util.ui.update.MergingUpdateQueue.execute(MergingUpdateQueue.java:320)在com.intellij.util.ui.update.MergingUpdateQueue.execute(MergingUpdateQueue.java:310)在com.intellij.util .ui.update.MergingUpdateQueue $ 2.run在com.intellij.util.ui.update.MergingUpdateQueue(MergingUpdateQueue.java:254)在com.intellij.util.ui.update.MergingUpdateQueue.flush(MergingUpdateQueue.java:269) . flush(MergingUpdateQueue.java:227)在com.intellij.util.ui.update.MergingUpdateQueue.run(M) ergingUpdateQueue.java:217)维持在java.util.concurrent.Executors $ RunnableAdapter.call(Executors.java:471)com.intellij.util.Alarm $请求$ 1.run(Alarm.java:289)在java.util中 . concurrent.FutureTask $ Sync.innerRun(FutureTask.java:334)在java.util.concurrent.FutureTask.run(FutureTask.java:166)在java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)是java java.lang.Thread.run中的.util.concurrent.ThreadPoolExecutor $ Worker.run(ThreadPoolExecutor.java:603)(Thread.java:722)

enter image description here

当我尝试使用Android GUI Designer(IntelliJ Utility)打开main.xml时,这是个例外 . 我有最新的IDE版本,所以我不知道这里发生了什么 .

回答(4)

2 years ago

IDEA还没有4.3的渲染版本 . 在预览的下拉菜单中尝试选择小于4.3的Android版本 . 这个对我有用 .

2 years ago

在预览选项卡中,只需打开最后一个下拉列表,然后选择较低的Android SDK . 就我而言,我选择了Android 4.4.2并且预览立即出现 .

2 years ago

IDEA与Android SDK Build-tools(18.1)的最新版本之间似乎存在不兼容性 . 安装稍旧版本18.0.1应该可以解决问题 .

2 years ago

在预览选项卡中,只需打开最后一个下拉列表,然后选择较低的Android SDK . 就我而言,我选择了Android 4.4.2并且预览立即出现 .

这个对我有用