Gradle,如何强制选择第三部分依赖项的最后版本

我有一些关于脏类路径的警告:

w: Runtime JAR files in the classpath have the version 1.2, which is older than the API version 1.3. Consider using the runtime of version 1.3, or pass '-api-version 1.2' explicitly to restrict the available APIs to the runtime of version 1.2. You can also pass '-language-version 1.2' instead, which will restrict not only the APIs to the specified version, but also the language features
w: C:\Users\gbarbieri\.gradle\caches\modules-2\files-2.1\org.jetbrains.kotlin\kotlin-reflect\1.2.50\9fab8887f91c8e17cce1a7522f45dc25976e57b9\kotlin-reflect-1.2.50.jar: Runtime JAR file has version 1.2 which is older than required for API version 1.3
w: C:\Users\gbarbieri\.gradle\caches\modules-2\files-2.1\org.jetbrains.kotlin\kotlin-stdlib-common\1.2.50\6b19a2fcc29d34878b3aab33fd5fcf70458a73df\kotlin-stdlib-common-1.2.50.jar: Runtime JAR file has version 1.2 which is older than required for API version 1.3
w: C:\Users\gbarbieri\.gradle\caches\modules-2\files-2.1\org.jetbrains.kotlin\kotlin-stdlib\1.2.50\66d47b004c5b8a1d2d1df9e463187390ed741316\kotlin-stdlib-1.2.50.jar: Runtime JAR file has version 1.2 which is older than required for API version 1.3

然后,我一直试图强制选择这些第三部分依赖项的最后一个版本:

constraints {
        testImplementation("$kotlin-stdlib:$kotlin_version")
        testImplementation("$kotlin-stdlib-jdk7:$kotlin_version")
        testImplementation("$kotlin-reflect:$kotlin_version")
    }

这适用于其他一些项目,但我似乎无法让它工作here

如果我跑了

gradle -q dependencyInsight --dependency kotlin-stdlib --configuration testCompileClasspath

我得到following

在Idea Gradle窗口中,我仍然可以看到一些不需要的依赖,例如 kotlin-reflect:1.2.50

为什么?

Ps:项目是这个one

回答(1)

2 years ago

显然这似乎有效:

project(":glm") {
    dependencies {
        constraints {
            testImplementation("org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version")
            testImplementation("org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version")
            testImplementation("org.jetbrains.kotlin:kotlin-reflect:$kotlin_version")
        }
    }
}

project(":glm-test") {
    dependencies {
        constraints {
            implementation("org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version")
            implementation("org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version")
            implementation("org.jetbrains.kotlin:kotlin-reflect:$kotlin_version")
        }
    }
}

但是,如果我尝试以这种方式将字符串的开头参数化为 constraints

buildscript {    
    ext{
        kotlin = 'org.jetbrains.kotlin:kotlin'
    }
}

然后它不再起作用了......很奇怪