Webpack es2015树与React一起摇晃

我想用树摇动功能似乎我们不需要安装babel-preset-es2015-webpack . 我们仍然可以使用babel-preset-es2015并将es2015预设的模块标志设置为false . 我更改了我的webpack配置,如下所示,这导致我的react组件中的导入行出现“意外的令牌导入”错误 .

module: {
    loaders: [
      {
        test: /\.js$/,
        exclude: /node_modules/,
        loader: 'babel',
        query: {
          presets: [['es2015', {modules: false}], 'react']
        }
      },
      {
        test: /\.scss$/,
        loader: ExtractTextPlugin.extract("style-loader", "css-loader!sass-loader")
      }
    ]
  }

我也尝试将预设设置为['es2015','react',{modules:false}]然后我在控制台上出现了不同的错误
模块构建失败:ReferenceError:[BABEL] C:\ FE-Proj-Templates \ webpack \ main.js:使用删除的Babel 5选项:foreign.modules - 在 plugins 选项中使用相应的模块转换插件 . 看看http://babeljs.io/docs/plugins/#modules

如何设置模块标志为false的预设es2015并使用React预设?

回答(1)

3 years ago

它已更新并且有效

presets: [['es2015', {modules: false}], 'react']