安装Appcelerator CLI时,appc setup命令会引发错误

我正在尝试安装appcelerator cli但仍然遇到一个我无法找到修复的问题 .

运行"appc setup"命令时出现错误"cannot find module 'C:\cyclic.js'" link to full screen capture of error

我正在运行Windows 7 64位,并遵循此处的指示https://web.appcelerator.com/product/cli

*编辑: If you are facing this same issue. Uninstall Node, and Appcelerator. Then make sure you install JDK 32 Bit (if using windows). DELETE the NPM and Appcelerator folders in your C:\Users[username]\AppData\Roaming\ directory. Then reinstall Node (I had success with 32 bit) and the Appcelerator CLI. That worked for me.

回答(3)

2 years ago

您好,请确保已安装node.js和JDK并正确设置环境变量 . 供参考http://docs.appcelerator.com/platform/latest/#!/guide/Installation_and_Configuration . 现在,你已经尝试了"appc setup" . 您需要删除以前安装的所有缓存,然后尝试重新安装 . 跑,

sudo rm -rf ~/.appcelerator 
sudo npm uninstall -g appcelerator 
appc use latest
appc setup

2 years ago

要设置Appcelerator CLI,请安装Node.js,使用NPM CLI安装appcelerator模块,然后运行appc setup命令以下载并设置最新的CLI软件包 . 您可以按照指南here进行操作 . 如果您在安装任何npm软件包时遇到问题,也可以查看link .

2 years ago

如果仍然没有解决,我建议你从头开始 . 我看到你在Windows上工作,是吗?:

  • 从"Uninstall programms"控制面板中删除NodeJS的安装

  • 从控制面板的"Uninstall programms"删除Appcelerator的安装

  • C:\Program Filesuser's folder 引用"node" "npm"或类似内容中删除任何文件夹 .

  • 转到 user's folder 并删除任何.app或.appcelerator文件夹(可隐藏,所以看起来不错)

  • 别忘了查看 C:\Users\[username]\AppData\Roaming (可能会隐藏)

现在你只安装了Java JDK(我使用的是1.8) .

继续安装新的appcelerator.EXE,它必须检测到您没有Node并且将自行下载正确的Node版本 .