安装PyQt5时出错

我想在我的Mac osx 10.9上安装PyQt 5,所以我做了以下事情:

  • 我下载了SIP并安装了它 .

  • 我下载了QT 5.3.2并由其安装程序安装,所以现在已经安装了

/ Users / username / Qt

所以我通过这样做将它添加到路径中

PATH = / Users / gollahalli / Qt / 5.3 / clang_64 / bin:$ PATH

出口PATH

  • 接下来我尝试通过执行以下操作来安装PyQt

python3 configure.py --qmake / Users / username / Desktop / PyQt

但我仍然得到这个错误

错误:PyQt5需要Qt v5.0或更高版本 . 你似乎在使用v3 . 使用--qmake标志指定正确的地震版本 .

知道出了什么问题吗?

回答(1)

3 years ago

你可以直接指向--qmake到二进制而不是顶层目录 . 在我的情况下,这是:

python3 configure.py --qmake ~/Qt5.4.1/5.4/clang_64/bin/qmake