如何使用Python3.4和SIP 4.19.1安装PyQt5?

我需要使用安装在我的XP机器上的Python3.4 . 现在我尝试使用Python34在Win10中安装PyQt5 . 但是,当我跑

pip3 install PyQt5

我明白了:

找不到满足要求SIP> = 4.19.1的任何下载

然后我尝试为SIP安装SIP froom PyPI download site,但它说Python版本是min . 3.5 . 即使是最旧的版本4.18也适用于Python3.5 .

有没有办法在Python34中使用PyQt5?或者,如果我使用Python36进行编写并使用pyinstaller将其打包在一个可执行文件中,我可以在XP中运行该应用程序吗?

回答(0)