我想为docker注册表部署portus,但是当我执行命令 - “docker-compose up -d”来安装portus时,出现了错误

以下是错误消息:

Post-install message from ruby-graphviz:

You need to install GraphViz (http://graphviz.org/) to use this Gem.

For more information about Ruby-Graphviz :
* Doc : http://rdoc.info/projects/glejeune/Ruby-Graphviz
* Sources : http://github.com/glejeune/Ruby-Graphviz
* Mailing List : http://groups.google.com/group/ruby-graphviz

Last (important) changes :
Ruby-Graphviz no longer supports Ruby < 1.9.3
  package golang.org/x/crypto/ssh/terminal: unrecognized import path "golang.org/x/crypto/ssh/terminal" (https fetch: Get https://golang.org/x/crypto/ssh/terminal?go-get=1: dial tcp 216.239.37.1:443: i/o timeout)
ERROR: Service 'portus' failed to build: The command '/bin/sh -c zypper addrepo https://download.opensuse.org/repositories/devel:languages:go/openSUSE_Leap_42.3/devel:languages:go.repo &&     zypper --gpg-auto-import-keys ref &&     zypper -n in --no-recommends ruby2.5-devel            libmysqlclient-devel postgresql-devel            nodejs libxml2-devel libxslt1 git-core            go1.10 phantomjs &&     zypper -n in --no-recommends -t pattern devel_basis &&     gem install bundler --no-ri --no-rdoc -v 1.16.0 &&     update-alternatives --install /usr/bin/bundle bundle /usr/bin/bundle.ruby2.5 3 &&     update-alternatives --install /usr/bin/bundler bundler /usr/bin/bundler.ruby2.5 3 &&     bundle install --retry=3 &&     go get -u github.com/vbatts/git-validation &&     go get -u github.com/openSUSE/portusctl &&     mv /root/go/bin/git-validation /usr/local/bin/ &&     mv /root/go/bin/portusctl /usr/local/bin/ &&     zypper -n rm wicked wicked-service autoconf automake            binutils bison cpp cvs flex gdbm-devel gettext-tools            libtool m4 make makeinfo &&     zypper clean -a' returned a non-zero code: 1

回答(0)