使用rbenv安装ActiveTcl的问题

ActiveTcl安装正确 . 然后,我试过:

CONFIGURE_OPTS="--with-tcl-dir=/opt/ActiveTcl-8.6 --enable-pthread" rbenv install 1.9.3-p429

这导致“建筑失败” .

现在,没有Ruby版本会安装 . 我正在使用rbenv,之前从未遇到麻烦 .

我只是想尝试TK和Ruby,但由于rbenv,路径的特殊配置是必要的,否则“require'tk”将无效 .

我怎样才能解除因滥用CONFIGURE_OPTS而造成的损害?如何正确设置rbenv ActiveTcl?

根据请求,这是我的“gem env”输出:

RubyGems Environment:
  - RUBYGEMS VERSION: 2.0.6
  - RUBY VERSION: 2.0.0 (2013-06-27 patchlevel 247) [x86_64-linux]
  - INSTALLATION DIRECTORY: /home/clyde/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0
  - RUBY EXECUTABLE: /home/clyde/.rbenv/versions/2.0.0-p247/bin/ruby
  - EXECUTABLE DIRECTORY: /home/clyde/.rbenv/versions/2.0.0-p247/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /home/clyde/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0
     - /home/clyde/.gem/ruby/2.0.0
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
     - "install" => "--no-ri --no-rdoc"
     - "update" => "--no-ri --no-rdoc"
     - "gem" => "--no-ri --no-rdoc"

回答(0)