对于角度为4的现有项目,安装npm失败

我在角度4上打招呼 . 我试图将角度4上的现有项目导入我的本地机器 . 我使用npm install来获取使用项目的package.json的nodes_modules,但是我收到了这个错误:
enter image description here

这是错误日志:

36096 warn @angular/material-moment-adapter@5.2.5 requires a peer of @angular/material@5.2.5 but none is installed. You must install peer dependencies yourself.
36097 warn bootstrap@4.0.0-beta.2 requires a peer of popper.js@^1.12.3 but none is installed. You must install peer dependencies yourself.
36098 warn ngx-malihu-scrollbar@1.2.2 requires a peer of @angular/core@^2.4.0 || ^4.0.0 but none is installed. You must install peer dependencies yourself.
36099 warn angular2-perfect-scrollbar@2.0.6 requires a peer of @angular/common@^2.0.0 but none is installed. You must install peer dependencies yourself.
36100 warn angular2-perfect-scrollbar@2.0.6 requires a peer of @angular/core@^2.0.0 but none is installed. You must install peer dependencies yourself.
36101 warn angular2-perfect-scrollbar@2.0.6 requires a peer of @angular/platform-browser@^2.0.0 but none is installed. You must install peer dependencies yourself.
36102 warn angular2-perfect-scrollbar@2.0.6 requires a peer of zone.js@^0.7.0 but none is installed. You must install peer dependencies yourself.
36103 warn @angular/compiler-cli@5.0.2 requires a peer of typescript@>=2.4.2 <2.5 but none is installed. You must install peer dependencies yourself.
36104 warn @angular-devkit/schematics@0.0.52 requires a peer of @angular-devkit/core@0.0.29 but none is installed. You must install peer dependencies yourself.
36105 warn @schematics/angular@0.1.17 requires a peer of @angular-devkit/core@0.0.29 but none is installed. You must install peer dependencies yourself.
36106 warn tsickle@0.24.1 requires a peer of typescript@2.4.2 but none is installed. You must install peer dependencies yourself.
36110 verbose stack Error: node-sass@4.7.2 postinstall: `node scripts/build.js`
36111 verbose pkgid node-sass@4.7.2
36113 verbose Windows_NT 10.0.14393
36114 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
36115 verbose node v10.13.0
36116 verbose npm  v6.4.1
36117 error code ELIFECYCLE
36118 error errno 1
36119 error node-sass@4.7.2 postinstall: `node scripts/build.js`
36119 error Exit status 1
36120 error Failed at the node-sass@4.7.2 postinstall script.
36120 error This is probably not a problem with npm. There is likely additional logging output above.
36121 verbose exit [ 1, true ]

这是我的package.json:

{“name”:“front-angular”,“version”:“0.0.0”,“license”:“MIT”,“scripts”:{“ng”:“ng”,“start”:“ng serve” ,“build”:“ng build”,“test”:“ng test”,“lint”:“ng lint”,“e2e”:“ng e2e”},“private”:true,“dependencies”:{“ @ angular / animations“:”5.0.2“,”@ angular / cdk“:”5.0.0-rc0“,”@ angular / common“:”5.0.2“,”@ angular / compiler“:”5.0 . 2“,”@ angular / core“:”5.0.2“,”@ angular / forms“:”5.0.2“,”@ angular / http“:”5.0.2“,”@ angular / material“:” ^ 5.2.0“,”@ angular / material-moment-adapter“:”^ 5.2.4“,”@ angular / platform-browser“:”5.0.2“,”@ angular / platform-browser-dynamic“: “5.0.2”,“@ angular / router”:“5.0.2”,“@ ngx-translate / core”:“8.0.0”,“@ ngx-translate / http-loader”:“2.0.0” ,“@ swimlane / ngx-charts”:“7.0.1”,“@ swimlane / ngx-datatable”:“11.1.2”,“angular2-text-mask”:“8.0.4”,“angular2-wizard” :“0.4.0”,“bootstrap”:“4.0.0-beta.2”,“compass-mixins”:“0.12.10”,“devextreme”:“^ 17.2.7”,“devextreme-angular”: “^ 17.2.7”,“font-awesome”:“4.7.0”,“jquery”:“3.2.1”,“material-design-iconic-font” :“2.2.0”,“mdi”:“2.0.46”,“时刻”:“^ 2.22.0”,“多品牌颜色”:“1.1.3”,“ng2-password-strength-bar “:”1.1.3“,”ng2-responsive“:”0.8.4“,”ng2-search-filter“:”0.3.1“,”ng2-validation“:”4.2.0“,”ng2-webstorage “:”2.0.0“,”ngbox“:”0.0.15“,”ngx-bootstrap“:”2.0.0-beta.8“,”ngx-ckeditor“:”0.1.1“,”ngx-malihu“ -scrollbar“:”1.2.2“,”ngx-perfect-scrollbar“:”5.0.2“,”ngx-uploader“:”4.2.1“,”node-sass“:”4.7.2“,”sweetalert2 “:”^ 7.18.0“,”ts-helper“:”0.0.1“,”web-animations-js“:”2.3.1“},”devDependencies“:{”@ angular / cli“:”1.5 .2“,”@ angular / compiler-cli“:”5.0.2“,”@ angular / language-service“:”5.0.2“,”@ types / jasmine“:”2.8.2“,”@ type / jasminewd2“:”2.0.2“,”@ types / node“:”8.0.53“,”angular2-perfect-scrollbar“:”2.0.6“,”codelyzer“:”4.0.1“,”copy- webpack-plugin“:”4.2.3“,”jasmine-core“:”2.8.0“,”jasmine-spec-reporter“:”4.2.1“,”业力“:”1.7.0“,”业力 - chrome-launcher“:”2.2.0“,”karma-cli“:”1.0.1“,”karma-coverage-istanbul-reporter“:”1.2.1“,”karma-jasmine“:”1.1.0“ , “K a rma-jasmine-html-reporter“:”0.2.2“,”量角器“:”5.2.0“,”ts-node“:”3.3.0“,”tslint“:”5.8.0“,”typescript“ :“2.6.1”}}

我正在使用:npm:v6.4.1 node:v10.13.0

谢谢 .
enter image description here

回答(1)

3 years ago

您使用Windows . Npm说Windows构建工具不是最新的 . 您必须升级Windows构建工具 . 试试这个命令: npm install --global --production windows-build-tools

另外,看看这里 . 也许它可以帮助:https://github.com/nodejs/node-gyp/issues/629#issuecomment-153196245