Home Articles

Bundler找不到gem“rails”的兼容版本:for spree

Asked
Viewed 981 times
0

我正在尝试将rails 4.0.4的安装与spree 2.2.2版本捆绑在一起,我面临以下问题:

Bundler找不到gem“rails”的兼容版本:在Gemfile中:spree(= 2.2.2)ruby依赖于spree_core(= 2.2.2)ruby依赖于rails(〜> 4.0.5)ruby

rails (4.0.4)

在我的Gemfile中:

宝石'狂欢','2.2.2'

宝石'spree_gateway',:git =>'https://github.com/spree/spree_gateway.git ', :branch => ' 2-2-stable'

宝石'spree_auth_devise',:git =>'https://github.com/spree/spree_auth_devise.git ', :branch => ' 2-2-stable'

1 Answer

  • 1

    我修复的上述错误的解决方案:按以下方式添加以下gem依赖项:

    宝石'spree',:git =>“https://github.com/spree/spree.git”,分公司:'2-1-stable'

    宝石'spree_auth_devise',:git =>“https://github.com/radar/spree_auth_devise.git”,分公司:'2-1-stable'

    哪个解决了我的问题,

    您还需要手动安装nokogiri

    gem install nokogiri - --use-system-libraries .

Related