Home Articles

Rails 4.0.0,Neo4j - Bundler找不到gem“railties”的兼容版本

Asked
Viewed 1012 times
1

我已经安装了jruby并试图将Neo4j用于我的Rails应用程序 . 但是输入bundle install会给我带来以下冲突 .

Bundler找不到gem“railties”的兼容版本:在Gemfile中:neo4j(> = 2.2.3)java依赖于栏目(<3.3,> = 3.0.0)java rails(= 4.0.0)java依赖于栏目(4.0.0)

这是我的gemfile:

source 'https://rubygems.org'

gem 'rails', '4.0.0'
gem 'sass-rails'
gem 'uglifier', '>= 1.3.0'
gem 'coffee-rails'
gem 'therubyrhino'
gem 'jquery-rails'
gem 'turbolinks'
gem 'jbuilder', '~> 1.2'

group :doc do
  gem 'sdoc', require: false
end
gem 'bcrypt-ruby', '~> 3.0.0'
gem 'unicorn'
gem 'capistrano', group: :development

group :development, :test do
  gem "rspec-rails"
end

gem "neo4j", ">= 2.2.3"

我应该删除我的Gemfile.lock并运行bundle update吗?谢谢!

2 Answers

  • 5

    neo4j项目中有一个rails 4的分支,所以你可以在Gemfile中指定它:

    gem 'neo4j', git: 'git://github.com/andreasronge/neo4j.git', branch: 'rails4'

  • 3

    这表示当前可用的neo4j版本需要一个版本的栏目<3.3,但是rails 4.0.0需要版本4.0.0的栏目:bundler无法解决这种冲突 .

    唯一的出路是将neo4j更新为使用rails 4.0 . 完全有可能neo4j对铁路的版本限制只是一种预防措施 - 除了检查一切仍然在4.0下工作之外,没有什么可做的了 .

Related