首页 文章
  • 5 votes
     answers
     views

    Python 2.6 JCC Pylucene问题

    问候, 我正在尝试在Python 2.6中使用pylucene . 由于没有为2.6构建的Windows,我尝试构建源代码 . 首先,我构建JCC(windows,使用cygwin) python setup.py build running build running build_py [...] building 'jcc' extension error: None python setu...
  • 4 votes
     answers
     views

    在Mac上安装PyLucene

    我希望能够在我的Mac上使用pyLucene . 这些指令让我绝望地失去了,因为每一条设置或制作的指令都要求我在它之前做一些事情,并且很难知道从哪个窗口开始做什么和做什么 . 我已经下载了PyLucene . 我想知道的第一件事是我把文件夹放在哪里,因为这对我来说似乎不言自明 . 要使用它,我被告知我需要构建JCC,它包含在pylucene下载中 . 说明: 在命令行中,输入:$ python ...
  • 2 votes
     answers
     views

    ImportError:没有名为_jcc的模块

    我试图在python 2.7(windows)上安装pylucene四天 . 它需要JCC来构建和安装 . 在我处理了成千上万的不同错误之后,最后JCC成功地进行了构建和安装 . 至少,这就是我的想法 . 之后,我尝试导入jcc,但是我收到此错误: Traceback (most recent call last): File "<stdin>", li...
  • 1 votes
     answers
     views

    无法在mac上安装JCC(pylucene所需)

    我紧跟着installation guide for pylucene . 我无法通过第一步,这需要安装JCC . 要install JCC the instructions简要说明mac用户需要: 编辑setup.py并查看INCLUDES,CFLAGS,DEBUG_CFLAGS,LFLAGS和JAVAC中的值是否适合您的系统 . 这些值也将被编译到JCC的config.py文件中,并且在调用...
  • 0 votes
     answers
     views

    在Mac OS上安装JCC的问题

    我想使用Pylucene,它需要先安装JCC .当我运行 python setup.py build 时,它被错误停止,如下所示: found JAVAFRAMEWORKS = /System/Library/Frameworks/JavaVM.framework Loading source files for package org.apache.jcc... Constructing Jav...
  • 1 votes
     answers
     views

    pylucene:安装错误

    UPDATE question: 谢谢Favoretti! 我使用apt-get安装了jcc,pylucene下的makefile运行了一点,抛出了java错误,我也没有线索 . 这里是 . 你能告诉我它是什么错误吗? While loading org/apache/pylucene/search/PythonIntParser Traceback (most recent call last)...
  • 0 votes
     answers
     views

    在Linux上安装PyLucene 6.5.0的问题

    我最近搬到了python3,所以我正在尝试安装最新版本的Pylucene(版本6.5.0),它与python3兼容 . jcc3/sources/jcc.cpp: In function ‘PyObject* t_jccenv_strhash(PyObject*, PyObject*)’: jcc3/sources/jcc.cpp:214:27: error: expected ‘)’ befor...

热门问题