Home Articles

Bundler无法找到gem“rubyzip”的兼容版本

Asked
Viewed 793 times
1

我试图将docx-html gem添加到我的项目中,这是我在 bundle install 时得到的:

Bundler找不到gem“rubyzip”的兼容版本:在Gemfile中:zip-zip(> = 0)ruby依赖于rubyzip(> = 1.0.0)ruby docx-html(> = 0)ruby依赖于
docx(〜> 0.1.0)ruby依赖于
rubyzip(0.9.1)

我的Gemfile的一部分:

gem 'rubyzip'
gem 'zip-zip'
gem 'docx_replace'

我通过另一个StackOverflow问题的建议添加了行 gem 'zip-zip' . 如果我排除它,而不是捆绑安装错误我尝试启动服务器时收到以下错误:

`require':无法加载此类文件 - zip

如何在保持gem docx_replace的同时摆脱这些错误?

1 Answer

  • 1

    我还没弄清楚为什么,但由于某种原因改变Gemfile代码到这个工作:

    gem 'zip'
    gem 'docx_replace'
    

Related