Home Articles

Bundler找不到gem“actionpack” - Rails的兼容版本

Asked
Viewed 957 times
0

我是Ruby和Ruby on rails的新手,我需要在现有的rails项目上更改一些内容:

我已经为项目安装了许多必需的宝石,但是当我执行时: bundle install 我有下一个错误:

enter image description here

我一直在谷歌搜索并尝试了很多东西,但任何人都修复它 .

这是我的 Gemfile 内容:

source 'https://rubygems.org'

# Basicas
gem 'rails', '3.2.15'
gem 'mysql2'
gem 'actionpack', '3.2.15'
gem 'nokogiri', '1.3.3'

# Gestion y deployment
gem 'capistrano'
gem 'capistrano-db-tasks', require: false
gem 'capistrano-detect-migrations'
# gem 'rvm-capistrano'
gem 'capistrano-rbenv'
gem 'cape', '~> 1' # tareas rake via capistrano
gem 'exception_notification'

# General
gem 'paperclip'
gem 'cancan'
gem 'devise' # gem "devise_ldap_authenticatable"
gem 'inherited_resources'
gem 'meta_search'
gem 'tabletastic'
gem 'simple_form'
gem 'will_paginate'
gem 'show_for', git: 'https://github.com/plataformatec/show_for.git'
gem 'permanent_records'
gem 'acts_as_list'
gem 'paper_trail',  '~> 2'
gem 'dossier'
gem 'wicked_pdf'
gem 'deep_cloneable'
gem 'statistics'

# exportacion a excel
gem 'acts_as_xlsx' # xlsx para ActiveRecord
gem 'axlsx_rails' # xlsx para vistas

group :assets do
  gem 'sass-rails',   '~> 3.2.3'
  gem 'coffee-rails', '~> 3.2.1'
#  gem 'uglifier', '>= 1.0.3'
  gem 'jquery-rails'
  gem 'therubyracer', :platforms => :ruby

  gem 'less-rails'
  gem 'bootstrap-sass', '~> 2.3.1.0'
  gem 'font-awesome-sass-rails'
  gem 'bootstrap-datepicker-rails'
  gem 'bootstrap-datetimepicker-rails'
  gem 'bootstrap-wysihtml5-rails'
  gem 'bootswatch-rails' # temas para bootstrap
  gem 'chosen-rails'
  # gem 'turbo-sprockets-rails3'
end

group :development do
  gem 'thin'
  gem 'meta_request', '0.2.1'
  gem 'byebug'
  gem 'annotate', git: 'https://github.com/ctran/annotate_models.git'
  gem 'bullet'
  gem 'quiet_assets'
  gem 'better_errors'
  gem 'binding_of_caller' # para better_errors
  gem 'rails-erd' # entity diagrams

  gem 'guard'
  gem 'guard-rspec'
  gem 'guard-bundler'
  gem 'guard-spring'
  gem 'rb-inotify', require: false
  gem 'rb-fsevent', require: false
  gem 'rb-fchange', require: false
  gem 'growl' # linux/mac notifications
end

group :development, :test do
  gem 'rspec-rails'
  gem 'faker'
  gem 'machinist', '>= 2.0.0.beta2' # fixture replacement (blueprints)
  gem 'capybara'
  gem 'database_cleaner'
  gem 'awesome_print'
end

谢谢大家!

1 Answer

  • 0

    show_for需要与0.5.0不同的版本

    gem 'show_for', git: 'https://github.com/plataformatec/show_for.git'
    

    需要改变

    gem 'show_for', "~> version_that_can_work_with_actionpack_3"
    

Related